ドリトル (プログラミング言語)

出典: フリー百科事典『ウィキペディア(Wikipedia)』
移動: 案内検索

ドリトル (: Dolittle) は、教育用に設計されたプログラミング言語の一つ。またはその処理系。現大阪電気通信大学教授の兼宗進により開発された。名前の由来は「少しだけする」という意味の英語「do little」であり、「やることが少ない(簡単にプログラムを書ける)」という願いから。また、ヒュー・ロフティング児童文学作品『ドリトル先生』にも掛けられている。

特徴[編集]

ドリトルは教育用に適した以下の特徴を持つ。

プロトタイプベースオブジェクト指向言語
プロトタイプベースであるため、オブジェクト指向によるプログラミングを比較的容易に学ぶことができる。また、あらかじめ用意されている部品を利用することで容易にプログラムを作成できる。
日本語表記
命令語は日本語を元にしており、識別子にも日本語の文字を使える。構文がSOV型であるため、日本語に近い表記ができる。ただしわかち書きを行わなければならない。(例:「200 歩く」。「200」と「歩く」の間はスペースを空ける。助数詞は無視されるため、「200歩 歩く」という表記も可能)
母語でプログラミングできることを目指しており、現在、英語、朝鮮語、日本語に対応している。構文が日本語と同じSOV型である朝鮮語では自然な表記ができるが,SVO型である英語では不自然さがある。
タートルグラフィックス
タートル(亀)と呼ばれるカーソルを操作して図形などを描く機能がある。タートルの軌跡を追うことによりプログラムの動作を視覚的に確認できる。
衝突判定
画面上のタートルオブジェクトと図形オブジェクトは,移動するごとに衝突判定が行われる。衝突が起こったときの動作を記述することで,画面上のオブジェクト同士が相互作用するプログラムを書くことができる。これはゲームプログラムを作るのに便利な機能である。
音楽
ストトン表記と呼ばれる楽譜で演奏できる。これは「ドレミ」のような音階の読みによる楽譜であるため、音楽初心者でも気軽に作曲(音楽プログラミング)ができる。MIDIの豊富な音源が利用でき、効果音としての利用も可能。

動作環境[編集]

各版ともJavaにより開発されている。

  • オンライン版
  • WindowsLinux
  • Macintosh

ライセンス[編集]

フリーウェアである。ただし、雑誌ウェブによる再配布は事前に確認が必要。

プログラム例[編集]

かめ太=タートル!作る。

カメ=タートル! 作る。

時計=タイマー! 作る 0.1秒 間隔 500回 回数。 時計! 「かめ太! 10 歩く」 実行。

左=ボタン!”左”作る。 左:動作=「かめ太! 20 左回り」。

右=ボタン!”右”作る。 右:動作=「かめ太! 10 右回り」。

外部リンク[編集]